Статьи и заметки об информационных технологиях
Блудная статья
О компании// Статьи// Рубрикатор// Каталог оборудования//
Поиск// Карта сайта// RSS// Ссылки//

Настройка резервирования канала на маршрутизаторе Cisco [02.03.2007]

Как настроить переключение маршрутизатора Cisco на резервный канал связи при обрыве основного.
Этот пример подойдет для случая, когда маршрутизатор Cisco имеет два Serial-интерфейса, например, Cisco 3640 или аналог (в этом примере – Serial1/0 и Serial1/1). Каждый интерфейс подключен к отдельному провайдеру, соответственно, каждый провайдер предоставляет свой пул адресов. В примере у провайдера 1 пул адресов 10.0.0.0 (255.255.255.0), а у провайдера 2 – 10.0.1.0 (255.255.255.0). Клиенты при обоих работающих каналах связи пользуются каналом провайдера из своей подсети, а при отключении одного из них должны переключаться на резервный. Приведенная ниже конфигурация маршрутизатора Cisco решает эту задачу:

service timestamps debug uptime
service timestamps log uptime
no service password-encryption
hostname c3640
enable secret cisco

ip subnet-zero
no ip domain-lookup

interface Loopback0
 ip address 10.0.3.1 255.255.255.0
 no ip directed-broadcast

interface Ethernet0/0
 ip address 10.0.0.1 255.255.255.0
 ip address 10.0.1.1 255.255.255.0 secondary
 no ip directed-broadcast
 ip nat inside
 ip policy route-map ISP

interface Serial1/0
 ip address 192.168.0.6 255.255.255.252
 no ip directed-broadcast
 ip nat outside

interface Serial1/1
 ip address 192.168.0.10 255.255.255.252
 no ip directed-broadcast
 ip nat outside

ip nat pool PoolISP1 10.0.0.16 10.0.0.31 prefix-length 28
ip nat pool PoolISP2 10.0.1.16 10.0.1.31 prefix-length 28
ip nat inside source route-map NAT1 pool PoolISP1 overload
ip nat inside source route-map NAT2 pool PoolISP2 overload
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.5
ip route 0.0.0.0 0.0.0.0 192.168.0.9
no ip http server

access-list 1 permit 10.0.0.0 0.0.0.255
access-list 2 permit 10.0.1.0 0.0.0.255
access-list 100 permit ip 10.0.1.0 0.0.0.255 10.0.0.0 0.0.0.255
access-list 100 permit ip 10.0.0.0 0.0.0.255 10.0.1.0 0.0.0.255
route-map NAT1 permit 10
 match ip address 2
 match interface Serial1/0

route-map NAT2 permit 10
 match ip address 1
 match interface Serial1/1

route-map ISP deny 10
 match ip address 100

route-map ISP permit 20
 match ip address 1
 set ip next-hop 192.168.0.5

route-map ISP permit 30
 match ip address 2
 set ip next-hop 192.168.0.9

line con 0
 transport input none
line aux 0
 no exec
 transport input all
line vty 0 4
 exec-timeout 0 0
 password cisco
 login

end



del.icio.us News2 Digg Furl ma.gnolia Technorati Cosmos Blinklist Yahoo! My Web BlinkBits Blogmarks Co.mments.com Connotea De.lirio.us Fark Feedmelinks LinkaGoGo NewsVine Netvouz RawSugar ReddIt Scuttle Shadows Simply Smarking Spurl TailRank Wists Segnalo Добавить на Mr. Wong Добавить на Webnews Добавить на  Icio Добавить на Oneview Добавить на Folkd Добавить на Yigg Добавить на Linkarena Добавить на StumbleUpon Добавить на Slashdot Добавить на Netscape Добавить на Google Добавить на Diigo Забобрить эту страницу! Добавить в закладки МоёМесто.ru
Постоянный адрес страницы: http://www.hypercomp.ru/articles/cisco-router-serial-line-backup/

Комментарии [12]
Ваш комментарий
Имя *

Фамилия *

E-mail  

WWW  

Комментарий * :-) ;-) :-( :-D 8-) :-o :roll: :unknown: :lol: :bad: :good: :no: :oops:

  Введите код с картинки:


Рассмотрим простейшую конфигурация маршрутизатора Cisco из серии 2600, которые сохраняют свою популярность и по сей день, а именно – модели Cisco 2620 ...
Тематика статьи
Разное
Яндекс цитирования
Rambler's Top100 Рейтинг@Mail.ru
О проекте // Статьи // Рубрикатор // Поиск // Карта сайта // RSS // СсылкиTo the skies!

© hypercomp.ru, 1982-2018 Куап.ру - база данных российских банков
 hypercomp.ru