Статьи и заметки об информационных технологиях
Блудная статья
О компании// Статьи// Рубрикатор// Каталог оборудования//
Поиск// Карта сайта// RSS// Ссылки//

Настройка точки доступа Cisco 1242 AG с аутентификацией через RADIUS-сервер [21.02.2007]


В приведенном примере точка доступа Cisco 1242AG настроена на предоставление доступа к сети как компьютерам или ноутбукам с беспроводными адаптерами, так и беспроводным IP-телефонам, например, Cisco 7920. При этом используется аутентификация методом LEAP через RADIUS-сервер. В рассматриваемом случае RADIUS-сервер работает на сервере с установленным на него Cisco ACS (Access Control Server) – однако ничто не мешает установить его и на отдельно стоящий сервер (например, поставить FreeRadius под Linux). Также настроена отправка сообщений о состоянии устройства на SNMP-сервер. На беспроводном интерфейсе Dot11Radio0 (2,4 ГГц) настроены 2 субинтерфейса - для телефонов Dot11Radio0.2 (SSID беспроводной сети - TLAN) и для компьютеров Dot11Radio0.1 (SSID беспроводной сети - DLAN), на беспроводном интерфейсе Dot11Radio1 (5 ГГц) - только субинтерфейс для компьютеров Dot11Radio1.1 (IP-телефоны Cisco 7920 работают только на частоте 2,4 ГГц). В основной сети для каждого из двух VLAN'ов (DLAN и TLAN) настроено по пулу адресов на DHCP-сервере - все беспроводные устройства адрес получают автоматически. Такую настройку DHCP-сервера можно посмотреть в этой статье: http://hypercomp.ru/articles/configuring-cisco-2811-with-callmanager-express/.

no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
hostname ap-01
ip subnet-zero
ip domain name domain.com
ip name-server 192.168.0.203
aaa new-model
aaa group server radius rad_eap
  server 192.168.0.203 auth-port 1645 acct-port 1646
aaa group server radius rad_mac
aaa group server radius rad_acct
aaa group server radius rad_admin
aaa group server tacacs+ tac_admin
aaa group server radius rad_pmip
aaa group server radius dummy
aaa authentication login default local
aaa authentication login eap_methods group rad_eap
aaa authentication login mac_methods local
aaa authorization exec default local
aaa accounting network acct_methods start-stop group rad_acct
aaa session-id common
dot11 vlan-name DLAN vlan 1
dot11 vlan-name TLAN vlan 2
dot11 ssid dlan
  vlan 1
  authentication open eap eap_methods
  authentication network-eap eap_methods
  authentication key-management wpa
dot11 ssid tlan
  vlan 2
  authentication open eap eap_methods
  authentication network-eap eap_methods
username admin privilege 15 password 7 074A156B6C5C0D0215573F2B26
bridge irb

interface Dot11Radio0
  no ip address
  no ip route-cache
  encryption vlan 2 mode wep mandatory
  encryption vlan 1 mode ciphers tkip
  ssid dlan
  ssid tlan
  speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
  54.0
  station-role root
interface Dot11Radio0.1
  encapsulation dot1Q 1
  no ip route-cache
  bridge-group 254
  bridge-group 254 subscriber-loop-control
  bridge-group 254 block-unknown-source
  no bridge-group 254 source-learning
  no bridge-group 254 unicast-flooding
  bridge-group 254 spanning-disabled
interface Dot11Radio0.2
  encapsulation dot1Q 2 native
  no ip route-cache
  bridge-group 1
  bridge-group 1 subscriber-loop-control
  bridge-group 1 block-unknown-source
  no bridge-group 1 source-learning
  no bridge-group 1 unicast-flooding
  bridge-group 1 spanning-disabled

interface Dot11Radio1
  no ip address
  no ip route-cache
  encryption vlan 2 mode wep mandatory
  encryption vlan 1 mode ciphers tkip
  ssid dlan
  speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0
  station-role root
interface Dot11Radio1.1
  encapsulation dot1Q 1 native
  no ip route-cache
  bridge-group 254
  bridge-group 254 block-unknown-source
  no bridge-group 254 source-learning
  no bridge-group 254 unicast-flooding
  bridge-group 254 spanning-disabled

interface FastEthernet0
  no ip address
  no ip route-cache
  duplex auto
  speed auto
  hold-queue 160 in
interface FastEthernet0.1
  encapsulation dot1Q 1
  no ip route-cache
  bridge-group 254
  no bridge-group 254 source-learning
  bridge-group 254 spanning-disabled
interface FastEthernet0.2
  encapsulation dot1Q 2 native
  no ip route-cache
  bridge-group 1
  no bridge-group 1 source-learning
  bridge-group 1 spanning-disabled

interface BVI1
  ip address 192.168.0.198 255.255.255.0
  no ip route-cache
ip default-gateway 192.168.0.1
ip http server
ip http authentication aaa
no ip http secure-server
ip http help-path
http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
ip radius source-interface BVI1
snmp-server community OurCommunity RO
radius-server attribute 32 include-in-access-req format %h
radius-server host 192.168.0.203 auth-port 1645 acct-port 1646 key 0 1234567890
radius-server vsa send accounting
bridge 1 route ip
line con 0
  password cisco
  login
line vty 0 4
  password cisco
  login



del.icio.us News2 Digg Furl ma.gnolia Technorati Cosmos Blinklist Yahoo! My Web BlinkBits Blogmarks Co.mments.com Connotea De.lirio.us Fark Feedmelinks LinkaGoGo NewsVine Netvouz RawSugar ReddIt Scuttle Shadows Simply Smarking Spurl TailRank Wists Segnalo Добавить на Mr. Wong Добавить на Webnews Добавить на  Icio Добавить на Oneview Добавить на Folkd Добавить на Yigg Добавить на Linkarena Добавить на StumbleUpon Добавить на Slashdot Добавить на Netscape Добавить на Google Добавить на Diigo Забобрить эту страницу! Добавить в закладки МоёМесто.ru
Постоянный адрес страницы: http://www.hypercomp.ru/articles/configuring-cisco-1242ag-with-eap-over-radius/

Комментарии [68]
Ваш комментарий
Имя *

Фамилия *

E-mail  

WWW  

Комментарий * :-) ;-) :-( :-D 8-) :-o :roll: :unknown: :lol: :bad: :good: :no: :oops:

  Введите код с картинки:


IP-телефон Cisco 7941 (как и 7961) поддерживает протокол SIP, но его настройка под него отличается от настройки Cisco 7940, описанной в одной и ...
Тематика статьи
Разное
Яндекс цитирования
Rambler's Top100 Рейтинг@Mail.ru
О проекте // Статьи // Рубрикатор // Поиск // Карта сайта // RSS // СсылкиTo the skies!

© hypercomp.ru, 1982-2018 Куап.ру - база данных российских банков
 hypercomp.ru